Skip to content
Discussion options

You must be logged in to vote

Consistency between all boolean props across all components is the reason. See our API naming guidelines for details. We decided a long time ago to name boolean props/variables with consistent prefixes for clarity.

I would have expected TypeScript to have caught if you passed disabled instead of isDisabled. Was that not working for some reason?

Replies: 1 comment

Comment options

You must be logged in to vote
0 replies
Answer selected by GermanJablo
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Category
Q&A
Labels
None yet
2 participants